# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Legal Notices</td>
<td>4</td>
</tr>
<tr>
<td>1 Welcome to SOLIDWORKS PDM</td>
<td>7</td>
</tr>
<tr>
<td>- Securely Accessing Files</td>
<td>7</td>
</tr>
<tr>
<td>- Finding What You Need</td>
<td>7</td>
</tr>
<tr>
<td>- Working As a Team</td>
<td>8</td>
</tr>
<tr>
<td>- Managing Complex Projects</td>
<td>8</td>
</tr>
<tr>
<td>- Working with Familiar Tools</td>
<td>8</td>
</tr>
<tr>
<td>2 Creating a Local File Vault View</td>
<td>9</td>
</tr>
<tr>
<td>3 Logging In and Out</td>
<td>11</td>
</tr>
<tr>
<td>4 SOLIDWORKS PDM Explorer Views</td>
<td>12</td>
</tr>
<tr>
<td>- Displaying the File Vault Contents</td>
<td>13</td>
</tr>
<tr>
<td>- Using the File View</td>
<td>14</td>
</tr>
<tr>
<td>- Changing the View</td>
<td>14</td>
</tr>
<tr>
<td>5 Viewing Documents</td>
<td>15</td>
</tr>
<tr>
<td>- Viewing File History</td>
<td>16</td>
</tr>
<tr>
<td>6 Searching for Documents and Users</td>
<td>17</td>
</tr>
<tr>
<td>- The SOLIDWORKS PDM Search Tool Interface (For SOLIDWORKS PDM Professional only)</td>
<td>18</td>
</tr>
<tr>
<td>- Embedded Search Interface</td>
<td>19</td>
</tr>
<tr>
<td>- Using the Complete Search Form</td>
<td>20</td>
</tr>
<tr>
<td>- Saving a Search (For SOLIDWORKS PDM Professional only)</td>
<td>21</td>
</tr>
<tr>
<td>7 Checking Files In and Out</td>
<td>22</td>
</tr>
<tr>
<td>- Checking Files Out</td>
<td>22</td>
</tr>
<tr>
<td>- Using the Check Out Dialog Box</td>
<td>22</td>
</tr>
<tr>
<td>- Checking Files In</td>
<td>23</td>
</tr>
<tr>
<td>8 Adding Files to the Vault</td>
<td>25</td>
</tr>
<tr>
<td>- Creating Files</td>
<td>25</td>
</tr>
<tr>
<td>- Creating Files from Templates</td>
<td>25</td>
</tr>
<tr>
<td>- Adding Existing Files</td>
<td>26</td>
</tr>
</tbody>
</table>
Legal Notices

© 1995-2015, Dassault Systemes SolidWorks Corporation, a Dassault Systèmes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systemes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD and/or Simulation software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902; 8,817,028, 8,910,078; 9,129,083 and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SOLIDWORKS Products and Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Ltd.


Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government
(a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense, consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN 1995)

In the event that you receive a request from any agency of the U.S. Government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2015 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:

Portions of this software © 1998-2015 Geometric Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2015 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2015 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.

Copyright Notices for SOLIDWORKS Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2014 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for SOLIDWORKS Standard Product

© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for SOLIDWORKS PDM Professional Product

Outside In® Viewer Technology, © 1992-2012 Oracle
© 2011, Microsoft Corporation. All rights reserved.
Copyright Notices for eDrawings Products

Portions of this software © 2000-2014 Tech Soft 3D.
Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.
Portions of this software © 1998-2014 Open Design Alliance. All rights reserved.
Portions of this software © 1995-2012 Spatial Corporation.
The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.
SOLIDWORKS PDM lets you and your project or product team members access, store, change, and approve design data.

SOLIDWORKS PDM Standard is a new product based on SOLIDWORKS Enterprise PDM. It is included with SOLIDWORKS Professional and SOLIDWORKS Premium.

SOLIDWORKS PDM Professional is the name of the product previously called SOLIDWORKS Enterprise PDM. It is available as a separately purchased product.

This guide covers the essential skills you need to use SOLIDWORKS PDM efficiently. The project structures, workflows, and data cards described in this document are generic and will not reflect your company’s customizations.

This chapter includes the following topics:

- Securely Accessing Files
- Finding What You Need
- Working As a Team
- Managing Complex Projects
- Working with Familiar Tools

Securely Accessing Files

Data is stored in a central archive called a file vault, which can be regularly backed up and shared by the whole product team. To access files, you create a working folder on your local computer called a file vault view.

Logging in to the file vault view lets you access files for which you have permissions.

You check files out to edit them, so that no one else can make changes, though other users can still view and copy the files.

Finding What You Need

The SOLIDWORKS PDM user interface is integrated with Windows Explorer, with added menu options, toolbar buttons, and dialog boxes.

Use the tabs at the bottom of the right pane to identify files in the vault.

Use search to locate files and save and share frequently used searches.
Working As a Team

You can copy files and folders into the vault or create them using SOLIDWORKS PDM commands.
Your team can use an automated workflow for review and approval.
Your administrator, you, or other users can set up notifications. Notifications can let you know when something needs your attention. They can also inform other users in a workflow when you check in a file or change a file's state.
You can convert and print the files you work on. See Converting and Printing SOLIDWORKS Files on page 34.
You can reuse information in multiple projects by sharing documents. See Sharing Files (For SOLIDWORKS PDM Professional only) on page 35.

Managing Complex Projects

You can check referenced documents in and out along with their parents.
You can view lists of the components of assemblies and drawings in Bills of Material (BOMs).

Working with Familiar Tools

You can open documents from inside SOLIDWORKS or other CAD applications.
A file vault is a central archive for files and the database that stores information about them. To access files, you create a local file vault view that connects directly to the file vault.

To create a local view of a vault:

1. Run **View Setup** by doing one of the following:
   - On Windows 7 and Windows Server systems prior to Windows Server 2012, click **Start > All Programs > SOLIDWORKS PDM > View Setup**.
   - On Windows 8 and Windows Server 2012 or later, on the **Apps** screen, under **SOLIDWORKS PDM**, click **View Setup**.

2. Complete the View Setup screens.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Select servers</td>
<td>Select the archive server that contains the file vault.</td>
</tr>
<tr>
<td></td>
<td>If the server is not listed:</td>
</tr>
<tr>
<td></td>
<td>1. Click <strong>Add</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. In the Add server manually dialog box, enter the server name and port.</td>
</tr>
<tr>
<td></td>
<td>3. Click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Select vaults</td>
<td>Select a file vault.</td>
</tr>
<tr>
<td></td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Select location</td>
<td>Under <strong>Attach location</strong>, type or browse to the location for the file vault view on your local computer.</td>
</tr>
<tr>
<td></td>
<td>Under <strong>Attach type</strong>, select one:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Only for me</strong>.</td>
</tr>
<tr>
<td></td>
<td>• <strong>For all users on this computer</strong>.</td>
</tr>
<tr>
<td></td>
<td>Users must have Admin permissions on the computer.</td>
</tr>
<tr>
<td></td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Review actions</td>
<td>Click <strong>Finish</strong>.</td>
</tr>
</tbody>
</table>
Creating a Local File Vault View

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completed</td>
<td>Click <strong>Close</strong>.</td>
</tr>
</tbody>
</table>
You must log in to SOLIDWORKS PDM to work on files in the vault.

To log in:

1. Click the SOLIDWORKS PDM icon next to the file vault name.
2. Accept the license agreement and click **OK**.
   
   The license agreement only appears the first time you log in.

3. If a dialog box appears, type your **User name** and **Password**, and click **Log In**.

   If the file vault is configured for automatic login, no dialog box is displayed.

After you log in, the icon also appears in the notification area at the far right of the task bar.

Right-click this icon to:

- Log off
- Log back in
- Exit SOLIDWORKS PDM
- Display the Inbox to view notifications
- Permit the execution of tasks on the computer
- Access Help and select how Help is displayed:
  - Using SOLIDWORKS Web Help, which displays in a browser.
  - Using the locally installed help, which displays in a help window.
- Change how online Help is displayed
- Display the SOLIDWORKS Web site in your browser
- Create or edit a presence note
SOLIDWORKS PDM Explorer Views

When you log in to SOLIDWORKS PDM through Windows Explorer, the Explorer window is modified to help you work with files in the vault.

There are three SOLIDWORKS PDM Explorer views:

**File view**
Lists the files in the vault. This is the default view, shown here.

**Bills of Materials view**
For the current folder, lists named BOMs and computed BOMs that have been activated.

**Search view**
Shows the most recently used search.
This chapter includes the following topics:

- Displaying the File Vault Contents
- Using the File View
- Changing the View

## Displaying the File Vault Contents

The color of the folders you see when you expand the file vault indicates their status:

<table>
<thead>
<tr>
<th>Color</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>The folder is in a vault and you have access to it.</td>
</tr>
<tr>
<td>Blue</td>
<td>Log in or right-click and select <strong>Online</strong> to access this folder.</td>
</tr>
<tr>
<td>Gray</td>
<td>The folder is local and does not exist in the vault database. Right-click and select <strong>Add to File Vault</strong>.</td>
</tr>
<tr>
<td>Yellow</td>
<td>The folder is not in your local view of the vault and does not exist in the vault database.</td>
</tr>
</tbody>
</table>
Using the File View

When your display is set to show files, which is the default, the top section of the right pane shows the files and folders in the vault. This is also known as File View.

When Windows Explorer is set to show details, the file list includes these key SOLIDWORKS PDM file properties:

**Checked Out By**  The user who has checked out the file.

Mouse over the user's name to see a pop-up card with information about the user, including log in status, the number of files checked out, and a personal presence note if the user has created one.

**State**  The state in the workflow. For example, Under Editing or Waiting for Approval.

**Checked Out In**  The local path to the checked out file.

**Category**  The SOLIDWORKS PDM file category. Files can be assigned a category to make it easier to organize them or assign them to workflows.

Custom columns configured by your administrator may also appear in the file view.

Changing the View

The default view when you open a directory is file view.

To change the view, do one of the following:

- Click **Display > Show Bills of Materials** to display named and activated BOMs in the current directory.
- Click **Display > Show Search Results** to display the most recently used search.
To see additional information about a file, select it in the file view and click one of the tabs in the right pane. If you view the Preview tab, the selected file is copied into your local file vault view.

### Tab Description

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview</td>
<td>The preview appears on the left side. Right-click it and select display options.</td>
</tr>
<tr>
<td>Folder/File Data Card</td>
<td>Data cards are defined by your administrator to provide additional information about files.</td>
</tr>
<tr>
<td>Version</td>
<td>Each file in the vault has a version that increments when it is modified and checked in. A warning appears on the Version tab if the local version is not current with the file in the vault.</td>
</tr>
<tr>
<td>Bill of Materials</td>
<td>Displays a Bill of Materials (BOM) for SOLIDWORKS assemblies, drawings, and weldment parts.</td>
</tr>
<tr>
<td>Contains and Where Used</td>
<td>Files are often interdependent and are associated with each other by references.</td>
</tr>
<tr>
<td></td>
<td>The Contains tab lists files referenced by the selected file.</td>
</tr>
<tr>
<td></td>
<td>The Where Used tab lists files that reference the selected file.</td>
</tr>
<tr>
<td></td>
<td>See References for details.</td>
</tr>
</tbody>
</table>

To change the local version:

1. Select the file.
2. To get the latest version stored in the vault, click **Actions > Get Latest Version**.
3. To copy a specific version to the local vault view, click **Actions > Get Version**, and select the version to copy.

These options are not available if your user settings (assigned by your administrator) specify **Always work with latest version of files**.
This chapter includes the following topics:

- **Viewing File History**

**Viewing File History**

You can view the history of version and state changes for files.

To view a file’s history:

1. Select a file and click **Display > History** or right-click the file and click **History**.
2. In the History dialog box, select a version of the document to display its check in or transition details.

From the History dialog box, you can also:

- **View** the file in the SOLIDWORKS PDM File Viewer.
- **Get** the selected version as the active version in your file vault view.
- **Save** the file to a different name.
- **Compare** the selected version of a file with the one immediately preceding it.
- **Rollback** to a selected version. All versions more recent than the selected version are destroyed.
- **Revoke** your approval for a parallel transition to a new state.

A parallel transition requires multiple users to run the transition before the file's state changes. If you have run the transition but the required number of users have not completed the transition, you can change your mind and revoke your approval.

- **Print** the history.
SOLIDWORKS PDM has two search methods:

- The Search tool is available only for SOLIDWORKS PDM Professional. It lets you search for files and folders, and for metadata that is stored in the vault such as users.
- An embedded search that displays in Windows Explorer makes it easy to search for files and folders.

To display the SOLIDWORKS PDM Search tool, do one of the following:

- Expand the Open Search (SOLIDWORKS PDM menu bar) flyout menu and click Search Tool.
- Click Tools > Search Cards and select the search form to use.

To display an embedded search, do one of the following:

- Click Open Search (SOLIDWORKS PDM menu bar).
- Click Display > Show Search Results.

This chapter includes the following topics:

- The SOLIDWORKS PDM Search Tool Interface (For SOLIDWORKS PDM Professional only)
- Embedded Search Interface
- Using the Complete Search Form
- Saving a Search (For SOLIDWORKS PDM Professional only)
The SOLIDWORKS PDM Search Tool Interface (For SOLIDWORKS PDM Professional only)

The SOLIDWORKS PDM Search Tool lets you search in a separate window that contains some features of the Windows Explorer browser for SOLIDWORKS PDM Professional.

1. **Start Search** Begin the search after specifying search criteria.
2. **Favorites** Save frequently used searches.
3. **Searches** Select the search form to use.
4. **Search form** Specify search criteria. The **Complete Search** form is shown.
5. **Preview tabs** Contains the same tabs as the preview tabs in Windows Explorer.
To search using the SOLIDWORKS PDM Search tool:

1. In Windows Explorer, click expand the **Open Search** (SOLIDWORKS PDM toolbar) flyout menu and click **Search Tool**.
2. In the top-left pane of the Search window, expand the vault to search.
3. Under **Favorites** or **Searches**, select the search method.
4. In the upper-right pane, use the search form to define the search.
5. Click **Start Search** (SOLIDWORKS PDM Search toolbar) or **Search > Start Search**. The search results appear in the middle pane.

**Embedded Search Interface**

Use an embedded search to perform file and folder searches directly in Windows Explorer.

1. **Navigation pane**
   - Lets you browse vaults and folders.
Contains commands that apply to the selected file or folder. When you are logged in to a SOLIDWORKS PDM vault, the **Help** button on the Windows Explorer toolbar opens the SOLIDWORKS PDM File Explorer help.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2 Windows Explorer toolbar</td>
<td>Contains menus of commands that can be performed for the selected file or folder. In search view, the menu bar contains additional buttons that are used to perform searches.</td>
</tr>
<tr>
<td>3 SOLIDWORKS PDM menu bar</td>
<td>Displays the card you selected so that you can specify search criteria.</td>
</tr>
<tr>
<td>4 Search card</td>
<td>Shows the files and folders found in the search.</td>
</tr>
<tr>
<td>5 Search results</td>
<td>Display information about files you select from the search results list. These tabs are also available in file view.</td>
</tr>
<tr>
<td>6 Search view tabs</td>
<td>Provides access to the commands used for an embedded search.</td>
</tr>
</tbody>
</table>

### Using the Complete Search Form

Use the Complete Search form in the SOLIDWORKS PDM Search tool or in an embedded search to specify a wide range of search criteria.

You can search by filename, for a specific variable value in a data card, by workflow status, user name, etc.

The search criteria are cumulative. The search results must meet all search criteria.

See the online help for detailed information on entering search criteria for each tab.

The Complete Search form has these tabs:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Search based on</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name and Location</td>
<td>File or folder names and locations.</td>
</tr>
<tr>
<td></td>
<td>If you specify a location, it is used in conjunction with the search criteria on other tabs.</td>
</tr>
<tr>
<td>Cards</td>
<td>Data card values.</td>
</tr>
<tr>
<td>Variables</td>
<td>The value of variables stored in files.  You can specify conditions based on the value of variables to be used as the search criteria.</td>
</tr>
<tr>
<td>Checked in/Out</td>
<td>Files checked out or not checked out by users.</td>
</tr>
<tr>
<td>Tab</td>
<td>Search based on</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Version Data</td>
<td>File versions. Specify a comment entered when the version was created, the user who created the version, or date limits.</td>
</tr>
<tr>
<td>Workflow</td>
<td>Workflow states. Select a workflow state, a user who has made transitions, or date limits.</td>
</tr>
<tr>
<td>Label</td>
<td>File labels.</td>
</tr>
<tr>
<td>History</td>
<td>Text in file histories.</td>
</tr>
<tr>
<td>Content</td>
<td>Text in file content (limited to text-based files) and file properties.</td>
</tr>
</tbody>
</table>

Saving a Search (For SOLIDWORKS PDM Professional only)

Save frequently run search criteria as favorites. When you select a favorite search it is run immediately against the current contents of the file vault.

To save a search:

1. Set up search criteria.

2. Click **Add to Favorites** (SOLIDWORKS PDM Search toolbar) or **Search > Add to Favorites**.

3. In the Add to Favorites dialog box, type a name for the favorite.

4. Select the users and groups that can see the favorite and choose whether they can edit it.

5. Click **OK**.
Checking Files In and Out

When multiple users have access to files, checking them in and out prevents conflicts.

This chapter includes the following topics:

- **Checking Files Out**
- **Checking Files In**

### Checking Files Out

You must check files out to edit them or change their properties. Other users cannot change them but they can still open them for viewing and copying. The checked out status of files is shown in the file view, on the File Data Card, Contains, and Where Used tabs.

To check files out:

1. Select one or more files and click **Actions > Check Out** or right-click and click **Check Out**.
2. If you select a single file that does not contain references, the check out is complete.
   - Your name appears in the **Checked out by** column in the file view pane.
3. If you select multiple files or a file that contains references, the Check Out dialog box opens so that you can make check out choices.

### Using the Check Out Dialog Box

The Check Out dialog box contains features that are common to many SOLIDWORKS PDM dialog boxes that you use to manage vault files.

To check out files:

1. In the file view pane, select the files to check out.
2. Right-click and click **Check out**.
   - The Check Out dialog box opens.
1. Use the file list columns to view information about files and to take actions.
   Right-click the column headings to add or remove columns.
   Drag the headings to change the column order.
2. Use the toolbar buttons to navigate the file list and save the list as a text file or spreadsheet.
3. Right-click in the file list to display a shortcut menu of commands that help you select files.
4. View a summary of warning messages and notes.
   Click Help for a detailed description of the dialog box features.
3. Select one or more of the files in the file list and click Check Out.

Checking Files In

When you modify a file and check it in, its version number is incremented and it becomes available for checkout by others.

If you do not make changes, the version number is not incremented.

If you add files to your local file vault view, you must check them in to make them accessible to other users. See Adding Files to the Vault.

To check files in:
Checking Files In and Out

1. Select the file and click **Actions > Check In** or right-click the file and select **Check In**.

2. In the Check in dialog box, you can:
   - Check your changes in but retain control of the file by selecting **Keep Checked Out**. This creates a new version of the file that other users view and copy.
   - Review warnings, for example, the warning **The file is not updated** indicates that you need to rebuild each configuration in that file in SOLIDWORKS.
   - Select **Remove Local Copy**, so that the file no longer resides in your local file vault view.
   - Enter a **Comment** to identify your changes.

   Your user profile may require that you add comments. Even if it does not, adding comments is recommended. They appear in the file's History dialog box, can be used in searches, and provide history for files that are listed when you select **Get Version**.

   The **Comment** field is unavailable if you have not made changes.

3. Click **Check In**.
Adding Files to the Vault

You can see all files added and checked in to the vault by your team.

To add your own files to the vault, you can:

- Create new folders and files directly in the vault
- Add existing folders and files to the vault

To give others access to files you add, you must check the files in.

This chapter includes the following topics:

- Creating Files
- Creating Files from Templates
- Adding Existing Files

Creating Files

You can create folders or files from applications such as Windows Explorer, SOLIDWORKS, or Microsoft Word.

Complete the fields in the data card that describe and distinguish the file.

To create folders or files in the vault:

1. In Windows Explorer, navigate to the destination in the vault.
2. Right-click in the file view and select:
   - For a folder: **New > Folder**
   - For a file: **New > application**
     where *application* is the application used to create the file.

3. Type the folder or file name.
4. Complete the information in the Folder/File Data Card and click **Save** (Data Card toolbar).

Creating Files from Templates

Templates provide default starting points for files that are commonly used in a project, such as specifications or part, assembly, and drawing documents.

To create files from templates:
1. Right-click in the file view and select **New**.
The top of the list shows the available templates.

2. Select a template.
The data card for the file is displayed if **Show file data card when file is created** is specified for the template.

3. Verify or add information to the data card and click **Save** (Data Card toolbar).

**Adding Existing Files**

You can add files and folders that were created outside the vault by using standard Windows copy and move techniques. For example, you can use Windows Explorer to drag files and folders into the vault.

After you add the files, you must check them in to make them accessible.
Workflows

The workflow process consists of administrator defined states and transitions that are used to route documents for approval.

This chapter includes the following topics:

- Workflow States and Transitions
- Running a Normal Transition
- Running a Parallel Transition (For SOLIDWORKS PDM Professional only)
- Revoking a Parallel Transition (For SOLIDWORKS PDM Professional only)

Workflow States and Transitions

Files in the vault are associated with workflow states that represent where the files are in the approval process. Workflows also include transitions, which are the mechanisms that move a file from one state to another.

Your administrator creates the workflow by defining states and transitions and granting users permission to initiate state changes by way of these transitions. Running a transition indicates that you approve of the state change it controls.

Users can participate in two types of transitions:

- Normal - A file changes state when one user runs the transition.
- Parallel - A specified number of users must approve the transition before the file changes state. It is available only for SOLIDWORKS PDM Professional.

Until the required number of transitions have been run and the file has changed state, any user who has approved the transition can revoke their approval.

For many states, multiple transitions are available. Each directs the file to a different development path. For example:

<table>
<thead>
<tr>
<th>Initial State</th>
<th>Transition</th>
<th>New state</th>
</tr>
</thead>
<tbody>
<tr>
<td>Waiting for Approval</td>
<td>Passed Approval</td>
<td>Approved</td>
</tr>
<tr>
<td></td>
<td>Editing Required</td>
<td>Under Editing</td>
</tr>
<tr>
<td></td>
<td>Submit for Testing</td>
<td>Under Testing</td>
</tr>
</tbody>
</table>

Transitions can include dynamic notifications, which allow a user to enter a notification comment and direct it to other users.
Running a Normal Transition

With a normal transition, only one user needs to run the transition to move a document to a new state.

Depending on how your administrator has set up the workflow, changing state can also:

- Change a document’s revision number
- Automatically send notifications to other users, with optional dynamic notification features

See *User-defined Notifications*.

To change a workflow state:

1. Check in the files whose state you want to change.
2. Select the files, right-click, and select **Change State** and the state transition to use.
3. In the Do Transition dialog box, verify that **Change State** is selected for all files.
4. Enter a state transition **Comment**, which is added to the file history.
5. For transitions with dynamic notifications, enter a **Notification comment** and a recipient.
6. Click **OK**.

   The file list shows that the files have changed state.

**Related Topics**

*User-defined Notifications* on page 31

Running a Parallel Transition (For SOLIDWORKS PDM Professional only)

If a parallel transition has been created, multiple users must run the transition before the file actually changes state.

This example describes how User A and User B send a file back to editing by using a parallel transition with dynamic notification to change the file's state.

1. As the first user to run the transition, user A does the following:
   a) Navigates to the file, right-clicks or clicks **Modify > Change State > Editing required (0/2)**.
      The **(0/2)** indicates that no one has run the transition and two users are required.
      In the Do Transition dialog box, the **Warnings** column in the file list indicates that one more user is required.
   b) Ensures that **Change state** is checked for the file that is changing state.
   c) Enters a **Comment**.
      The comment appears in the file's history when the transition is run by other users.
d) Types a **Notification comment**.
e) Clicks **OK**.

The **State** column in the file list shows that the file did not change state.

2. After being notified by user A, user B does the following:
a) Navigates to the file, right-clicks or clicks **Modify > Change State > Editing required (1/2)**.

The **(1/2)** indicates that one person has run the transition and one more user is required.

In the Do Transition dialog box:

- The **Warnings** column is blank.

  When user B completes the transition, no other approvals are required.

b) Ensures that **Change state** is checked.
c) Enters a **Comment** and **Notification comment** and clicks **OK**.

The **State** column in the file list is unchanged.

### Revoking a Parallel Transition (For SOLIDWORKS PDM Professional only)

When you are one of the approvers for a parallel transition and the required number of approvals has not been reached, you can revoke your approval.

For example, in the scenario described in *Running a Parallel Transition*, if user B had not approved the transition, user A could have revoked approval.

**To revoke your approval in a parallel transition:**

1. Right-click the file for which you ran the transition or click **Modify > Change State** and select the transition to revoke.

   Transitions that can be revoked are shown as:

   📅 **Revoke 'transition_name (n/n+)’**

   where:

   - **transition_name** is the transition.
   - **n** is the number of users who have approved the transition.
   - **n+** is the number of approvals needed to change the file's state.

2. In the Revoke Transition dialog box, ensure that **Revoke** is enabled for the file.
3. **Click OK**.

You can also display the file's history, select the transition you approved, and click 📅 **Revoke**.
SOLIDWORKS PDM provides two types of notifications to communicate changes between team members.

- Manual notifications that you send explicitly.
- Automatic notifications generated by changes to projects in the vault.

Use the SOLIDWORKS PDM Notification Editor to create customized multiple notification assignments for individual files and entire folders.

This chapter includes the following topics:

- Manual Notifications
- Automatic Notifications

Manual Notifications

You can use notifications to send the equivalent of email messages to other team members.

To send text messages to team members:

1. Click **Tools > Notify > A Colleague**.
2. Specify a recipient, type a message, and click **Send**.

When the recipient logs in to the vault, the SOLIDWORKS PDM icon on the right side of the notification area changes to indicate that there is a message. Clicking the icon displays the message.

**Notifying a User Who Has Checked Out a File**

To send text messages to the person who has checked out a file:

1. Right-click the file in the vault and click **Notify > User who has checked out file**.
   
   The recipient is already selected and a link to the selected file is embedded in the message.

2. Type the message.
   
   For example, you might want to ask the user to check the file in so you can modify it.

3. Click **Send**.

   The recipient receives an email with your message and the link to the file. When the recipient clicks the link, an Explorer window opens with the file selected.
Automatic Notifications

Notifications can be sent automatically as a result of changes to the file vault.

Administrator-defined Notifications

Your administrator can configure notifications to be sent when the workflow state of a document changes.

For example, a notification can alert the next person in the document’s life cycle to take action on the file. If an administrator selects the dynamic notification option, users can add notification comments and select recipients.

User-defined Notifications

You can set up notifications to be sent to yourself when changes are made to files.

To set up automatic notification for an individual file:

1. Right-click the file and select Notify.
2. Select one of the following options to specify when you are to be notified.
   - Me when checked out
   - Me when checked in
   - Me when state enters
     Expand the menu to select a state.
   - Me when state leaves
     Expand the menu to select a state.

Setting Up File Notifications

You use the File Notification dialog box to set up custom notifications for files.

To set up notifications for a file:

1. Do one of the following:
   - With a file selected, click Tools > Notify > Me when.
   - Right-click a file and click Notify > Me when.

   The File Notification dialog box opens.

2. From the Type drop-down list, select one of the following:
   - Change Workflow State
   - Check in
   - Check out
   - Delayed in State

   The Notification Properties tab updates to reflect the options available for the notification type you select.

3. Complete the fields for the notification type you selected.
4. Optionally, restrict the notification to files you have created or files for which you were the last user to change state.

Not available from Delayed in State notifications.

5. Click OK.
The Notification Editor opens, listing your notifications.
Use this dialog box to edit or remove notifications you have created.
If a notification was created for you by your administrator, you cannot remove it, but you can view its details.

6. Click OK.

Setting Up Folder Notification
You use the Notification Editor to create notifications that apply to all the files in a folder.

1. Do one of the following:
   • With a folder selected, click Tools > Notify > Me when.
   • Right-click a folder and click Notify > Me when.
   
   The Folder Notification dialog box opens.

2. From the Type drop-down list, select one of the following:
   • Add File
   • Change Workflow State
   • Check in
   • Check out
   • Deadline
   • Delayed in State

3. Complete the fields for the notification type you selected.

4. Optionally, restrict the notification to files you have created or files for which you were the last user to change state.

Not available for Deadline or Delayed in State notifications.

5. Click OK.
The Notification Editor opens.

6. Click OK.
Tasks (For SOLIDWORKS PDM Professional only)

If you have permission, you can use administrator-defined tasks to convert or print SOLIDWORKS files from File Explorer. You can also validate SOLIDWORKS document designs.

Administrators use the Task feature in the Administration tool to configure, run, and monitor tasks that team members perform frequently on SOLIDWORKS PDM files. Tasks your administrator can configure include:

- **Convert Files**: Converts files to specified format.
- **Design Checker**: Validates selected SOLIDWORKS documents in the vault using standards created in the SOLIDWORKS Design Checker add-in.
- **Print Files**: Prints files according to options you set.

For details about completing task, click Help in the Task dialog boxes.

The task help appears in English for the following languages: Czech, Korean, Polish, traditional Chinese.

If your administrator has configured one or more of these tasks, you can initiate them by selecting files, right-clicking, and clicking Tasks > task_name.

Your administrator might have chosen different names for these tasks.

How you use a task depends on how your administrator sets it up. To configure tasks, administrators:

- Name the command that appears in the menu
  By default, the commands Convert Files, Design Checker, and Print Files are grouped under a Tasks submenu. You might see additional or differently named commands.
- Assign permissions
  Task commands are only visible if you have permission to initiate the tasks.
- Set task defaults such as conversion and printing settings
- Specify which default settings you can change
  Settings you can edit are shown in the task’s dialog box.
- Select users or groups to be notified when a conversion or print task succeeds or fails
Notifications appear in your SOLIDWORKS PDM Inbox.

- Specify whether a task input card is displayed when you launch the task

This chapter includes the following topics:

- Converting and Printing SOLIDWORKS Files
- Validating SOLIDWORKS Designs

Converting and Printing SOLIDWORKS Files

If you have permission, you can convert or print SOLIDWORKS files by selecting a convert or print command.

To convert or print a file:

1. Select one or more files.
2. Right-click and click **Tasks > task_name**.
   - The default commands are **Convert Files** and **Print Files**.
3. Optionally, change the settings in the dialog box that appears.
4. Launch the task by clicking **OK** for conversion tasks or **Print** for print tasks.
5. If a second dialog box appears, provide additional information need to complete the task and click **OK**.

Validating SOLIDWORKS Designs

You can validate SOLIDWORKS designs by selecting the Design Checker task. You must first create a Design Checker Standards file using the SOLIDWORKS Design Checker add-in.

To validate the design of a SOLIDWORKS file:

1. Select one or more files.
2. Right-click and click **Tasks > Design Checker**.
3. In the Design Checker dialog box:
   a) Select the Design Checker Standards file to use.
   b) If you want SOLIDWORKS to correct failed design checks, select **Auto correct all failed checks**
   c) Select how Design Checker reports are handled.
   d) Specify the log file path.
4. Launch the task by clicking **OK**.
Sharing Files (For SOLIDWORKS PDM Professional only)

You can share a file between two folders so that changes made to it are automatically updated in all locations in the vault. Shared files are marked with a yellow plus-sign in the icon in the Windows Explorer view. To view updates locally, get the latest version of the file.

To share files:
1. Right-click the file and select **Copy**.
2. Right-click the destination folder and select **Paste Shared**.

To work with shared files:
1. Check the file out from the source location or a shared location.
   - All other instances of the file are checked out.
2. Open and edit the file from the location where you checked it out.
3. Check the file in to the same location.
   - The modifications are saved to all instances of the file.
13

References

CAD files typically have references that tie parts to assemblies, or parts and assemblies to drawings. These references are stored in the SOLIDWORKS PDM database as part of a document’s metadata.

When you save a version of the parent (referencing) file, it is associated with the current versions of its referenced files. For example:

<table>
<thead>
<tr>
<th>Assembly Versions</th>
<th>Parts Versions</th>
<th>Versions as shown on the Contains tab</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cat Gym Version 2</td>
<td>Base Version 5</td>
<td><img src="image" alt="Diagram" /></td>
</tr>
<tr>
<td>Column Version 2</td>
<td><img src="image" alt="Diagram" /></td>
<td></td>
</tr>
<tr>
<td>Cat Gym Version 3</td>
<td>Base Version 7</td>
<td><img src="image" alt="Diagram" /></td>
</tr>
<tr>
<td>Column Version 3</td>
<td><img src="image" alt="Diagram" /></td>
<td></td>
</tr>
</tbody>
</table>

When you use the Get Version option to retrieve a specific version of the parent file, the correct referenced versions are retrieved. Referenced drawings may not be in the same directory as the assembly. An assembly can reference SOLIDWORKS Simulations files in addition to parts, subassemblies, and drawings.

To see the reference versions associated with each version of a parent file:

1. Select the parent file and click the Contains tab.
2. Select the parent file version and view the reference file versions in the list.

This chapter includes the following topics:

- Checking Files with References In and Out
- Copying References
- Moving References (For SOLIDWORKS PDM Professional only)
- Manually Adding File References
- Updating Broken File References
Checking Files with References In and Out

When you check out a file with references, you can also check out referenced files, including drawing (.slddrw) references.

When you check in a file with references, you can check in the referenced files at the same time.

Copying References

You can copy a parent file with all its references to create a second instance unrelated to the original. For example, you can copy a document set to use it as the basis for a new document set. The newly copied parts start with a new version history.

Copy Tree Interface

Use the Copy Tree dialog box to copy a parent file with all its references to create a second instance unrelated to the original.

To display the dialog box, select the parent file and click Tools > Copy Tree.

The Copy Tree options include the following:

<table>
<thead>
<tr>
<th>Default Destination</th>
<th>Displays the current folder location of the selected files. You can change the destination path using Browse.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings</td>
<td>Lets you select:</td>
</tr>
<tr>
<td></td>
<td>• Version of the file to copy.</td>
</tr>
<tr>
<td></td>
<td>• Copy type of the destination folder.</td>
</tr>
<tr>
<td></td>
<td>• Options for including specific file types for copy, setting the path for the destination folder, regenerating the serial number in cards, and setting the drawing file names.</td>
</tr>
<tr>
<td>Transform Operations</td>
<td>Lets you rename the target file names of the selected files.</td>
</tr>
<tr>
<td>Filter Display</td>
<td>Lets you refine the list of files displayed. You can filter the file list based on columns, file type, selected for copy or not, and path/name changed or not.</td>
</tr>
<tr>
<td></td>
<td>The search field of the filter display supports these wildcard characters: *, ?, %, &quot;,&quot;, &quot;.&quot;.</td>
</tr>
</tbody>
</table>
### File List

Lets you do the following:
- Select files to copy.
- Select files to rename using transforms.
- Verify new file names and paths.

You can select the columns to display or to hide by right-clicking any column heading and selecting the columns.

The **Destination Folder Path** and **Target File Name** columns are editable. For example, you can edit the default destination folder by using the button, and rename the target files by using transform operations.

<table>
<thead>
<tr>
<th>Total to Copy</th>
<th>Displays the number and type of files you have selected for copying.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reset All</td>
<td>Resets the destination folder paths and target file names to the original names.</td>
</tr>
</tbody>
</table>

### Moving References (For SOLIDWORKS PDM Professional only)

You can move a parent file with its partial or entire folder structure, including related drawings, to another folder or to multiple folders.

### Move Tree Interface (For SOLIDWORKS PDM Professional only)

Use the Move Tree dialog box to move partial or entire file and folder structures, including related drawings, to another folder or to multiple folders.

To display the dialog box, select the parent file and click **Tools > Move Tree**.

The Move Tree options include the following:

<table>
<thead>
<tr>
<th>Default Destination</th>
<th>Displays the current folder location of the selected files. You can change the destination path using <strong>Browse</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings</td>
<td>Lets you select options for including specific file types for move, setting the path for the destination folder, and regenerating the serial number in cards.</td>
</tr>
<tr>
<td>Transform Operations</td>
<td>Lets you rename the target file names of the selected files.</td>
</tr>
</tbody>
</table>
Filter Display

Lets you refine the list of files displayed. You can filter the file list based on columns, file type, selected for move or not, and path/name changed or not.

The search field of the filter display supports these wildcard characters: *, ?, %, -, ., "".

File List

Lets you do the following:
- Select files to move.
- Select files to rename using transforms.
- Verify new file names and paths.

You can select the columns to display or to hide by right-clicking any column heading and selecting the columns.

The Destination Folder Path and Target File Name columns are editable. For example, you can edit the default destination folder by using the button, and rename the target files by using transform operations.

Total Selected

Displays the number and type of files you have selected for moving.

Reset All

Resets the destination folder paths and target file names to the original names.

Manually Adding File References

You can create references (links) between documents such as PDFs, spreadsheets, and images so that when you open the parent file, you can open referenced documents at the same time.

Examples:
- 3D component of a motor with the PDF specification file
- Digital image of a building with the renovation drawing in SOLIDWORKS

To create a reference:

1. Right-click the parent file and select Check Out.
2. Right-click the files you want to reference and select Copy.
3. Right-click the parent file and select Paste as Reference.
4. In the Create File References dialog box, set options and click OK.
   - **Add Reference**: Creates a reference to the file.
   - **Show in Bill of Materials**: Includes the file in the parent file’s BOM.
   - **Quantity**: Specifies the quantity of the referenced files to include in the Bill of Materials and Contains tabs.
5. Right-click the parent file and select Check In.
6. To verify the references, select the parent file and select the Contains tab
To modify or remove a reference:

1. Check out the parent file.
2. On the Contains tab, click **Edit user defined reference**.
3. In the Edit User-Defined File References dialog box:
   - To remove a reference, clear **Referenced**.
   - To change whether a referenced file is in the BOM, select or clear **Show in Bill of Materials**.
   - To modify the quantity of referenced files to include, change the value in the **Quantity** column.
4. Click **OK**.
5. Check in the parent file.

Updating Broken File References

You can use the **Update References** command to repair broken file references.

- You can repoint references to existing files in the vault.
- If the referenced files are outside the vault, you can locate them, update the references, and add the files to the vault.
- You can replace existing references.

**Warning messages appear when you try to check files with broken references into the vault.**

To update the references, cancel the check in and complete the following procedure:

1. Select a file with broken references.
2. Click **Tools > Update References**.

   The Update References dialog box opens, listing all references and identifying those that are missing.

3. If a warning indicates that a file cannot be found, click **Find Files** (Update References toolbar).
4. In the Find Files wizard, select the folder to search, specify how the search should be performed, and click **Next**.

   Files that meet your search criteria are listed.
5. If the **Found in** column indicates that there are multiple matches, expand the list and select the file to use.
6. To update a reference, in the **Update** column, check the box and click **Finish**.
7. Click **OK** in the Update References message box.
8. Click **Update** to save the reference paths that are shown in the **Found In** column to the parent file.

Menu options in the Update References dialog box let you:

- Save the file list as a CSV file
- Open the file list in Excel
- Change the view of columns
- Replace a selected reference
- Add a file to the vault if it is found outside the vault
See SOLIDWORKS PDM File Explorer Help: Updating File References for more information.
Using SOLIDWORKS PDM in SOLIDWORKS

The SOLIDWORKS PDM client for SOLIDWORKS lets you access the vault from within the SOLIDWORKS application.

To enable the add-in:

1. In SOLIDWORKS, select **Tools > Add-Ins**.
2. In the Add-Ins dialog box, select both **Active Add-Ins** and **Start Up** for **SOLIDWORKS PDM Client**.

This chapter includes the following topics:

- **SOLIDWORKS User Interface Additions**
- **Versioning SOLIDWORKS Files**
- **SOLIDWORKS File References**
- **SOLIDWORKS File Properties**
SOLIDWORKS User Interface Additions

When SOLIDWORKS PDM is added in to SOLIDWORKS, the SOLIDWORKS PDM menu and task pane provide access to and information about files in the vault.

To open a vault file from SOLIDWORKS:
1. Select **File > Open**.
2. In the Open dialog box, navigate to the file in the vault.
3. Click **Open** and click **Yes** at the prompt to check out the file.

   If the file you are checking out contains references to other files, the Check Out dialog box opens.

   If you open a file without checking it out, you can check it out later from the task pane or from the FeatureManager design tree.

To check out a file from the graphics window or task pane:
1. Select the file in the graphics window, from the SOLIDWORKS PDM tab on the task pane, or from the FeatureManager design tree.
2. Click **Check Out** (SOLIDWORKS PDM task pane toolbar) or right-click and select **Check Out**.
If the file you are checking out contains references to other files, the Check Out dialog box opens.

3. Select the files to check out and click **Check Out.**

**Versioning SOLIDWORKS Files**

SOLIDWORKS PDM lets you modify files, retain a history of all file changes, and retrieve older versions of files. The interaction of references and versioning is important because SOLIDWORKS assemblies and drawings reference subassemblies and components.

See **SOLIDWORKS File References**.

When you open a file, you get the local version by default. If there is no local version of the file, the latest version from the file vault is opened.

To retrieve a specific version of an assembly and the appropriate versions of its referenced parts:

1. In the SOLIDWORKS PDM task pane, right-click the assembly file and select **Get**.
2. In the Get dialog box, select the version of the assembly and click **OK**.

To retrieve the latest version of an assembly and its referenced parts:

1. In the SOLIDWORKS PDM task pane, right-click the assembly file and select **Get Latest Version**.
2. In the Get dialog box, ensure that **Get** is checked for all files, and click **Get**.

**SOLIDWORKS File References**

SOLIDWORKS PDM does not change the way SOLIDWORKS references or searches for files.

In SOLIDWORKS, an external reference is created when one document is dependent on another document for its solution. If the referenced document changes, the dependent document changes also.

Referenced files can be stored in multiple locations. The SOLIDWORKS commands **Find References** and **List External References** show the references and their locations.

**SOLIDWORKS File Properties**

SOLIDWORKS has unique properties that are more suited to engineering than the default properties associated with other Windows documents. You can add properties such as a descriptive title, the author name, the subject, or keywords and use them to search for a file or display information about it.

When you add a SOLIDWORKS document to a file vault, some of its properties are added to the file data card. Similarly, if you create a SOLIDWORKS document from within SOLIDWORKS PDM, properties you specify for the file data card appear in SOLIDWORKS. Click **File > Properties**, and select the Custom tab to view these properties.
SOLIDWORKS PDM includes functionality to help you display and work with bills of materials (BOMs). When you select an assembly, drawing, or weldment part in the file view, the Bill of Materials tab displays a table of the components in the file.

This chapter includes the following topics:

- **BOM Types**
- **BOM Templates (For SOLIDWORKS PDM Professional only)**
- **BOM Toolbars**
- **Bills of Materials (BOM) View**

### BOM Types

You can work with these types of BOMs in SOLIDWORKS PDM:

- **Computed BOMs** are automatically calculated from the SOLIDWORKS components in an assembly or drawing. Computed BOMs reflect BOM exclusions you make in the SOLIDWORKS assembly and components.

  You can check out BOM components and change their data card properties. You can also edit quantities and variable values in a computed BOM if you check out the assembly or drawing and components on which it is based. You cannot add items to a computed BOM, check it in or out, or change its state.

- **SOLIDWORKS BOMs** are BOM tables in SOLIDWORKS assemblies and drawings. SOLIDWORKS PDM displays the BOM table you maintain in SOLIDWORKS. You cannot edit the BOM in SOLIDWORKS PDM.

- **Named BOMs** are editable BOMs that you create from computed BOMs or SOLIDWORKS BOMs. These are available in SOLIDWORKS PDM Professional only.

  When you create a named BOM, it is checked out to you so that you can edit it. When you view the named BOM in the Bills of Materials view, you can check it in, view its history, and modify its state if it is defined in your workflow. Named BOMs are specific to the version of the assembly or drawing used to create them. You can update the BOM on which a named BOM is based to a new version of the assembly or drawing.

- **Weldment Cut Lists** and **Weldment BOMs** are for weldment parts. A weldment BOM lists each component in the weldment part with its total length. A cut list contains the cut lengths and quantities of the components.
BOM Templates (For SOLIDWORKS PDM Professional only)

The fields shown in computed BOMs, weldment BOMs, and weldment cut lists depend on BOM templates that your administrator configures. Your administrator can create multiple BOM templates based on different data card variables. For example, BOMs for engineers or designers might have Quantity, Description, and Material columns, while BOMS for purchasing managers have Vendor, Cost, and Part Number columns.

Your administrator also controls user access to BOMs. The BOMs available on the Bill of Materials tab depend on your permissions.

BOM Toolbars

Toolbar options on the Bill of Materials tab let you control how the BOM is displayed and run the commands that are available for the BOM you are viewing.

The toolbar options are organized in sections. The options are fully displayed when there is room in the Explorer window. For example, when you view a computed BOM and fully expand the right pane, you see:

When the Explorer window is too narrow, as many sections of the toolbar as necessary are compacted into flyout buttons. Clicking any of these buttons displays the controls for that section. For example,

The section names are only displayed when the user interface is compacted.

The sections are compacted in this order:

1. **View**
2. **Options**
3. **Commands**
4. **File**

The options that are available and the toolbar organization depend on the type of BOM you are viewing. Click *Help* on the Bill of Materials tab to display details for the BOM type you are viewing.

In general:
- The View section identifies the BOM you are viewing and lets you select a different BOM and control the organization of the file list.
- The Options section lets you activate the BOM and refine the display.
- The File section identifies the file whose BOM is displayed and lets you select the file version and configuration to view.
- The Commands section contains buttons that let you perform actions on the BOM.

When you click **Compare** in the Commands section, the toolbar layout changes to let you select the BOMs to compare.

---

### Bills of Materials (BOM) View

The Bills of Materials view lists the named BOMs for the current folder and any BOMs that have been activated.

To switch to BOM view, click **Display > Show Bills of Materials**.

The lower pane contains most of the options on the Bill of Materials tab in the Files view.

In BOM view, you can right-click a named BOM to access commands such as **Check In**, **Change State**, or **History**.

All named BOMs in a directory are displayed automatically in BOM view. You can also display computed BOMs and SOLIDWORKS BOMs by activating them.

To activate a computed BOM:

1. Select the assembly or drawing in the file view.
2. On the Bill of Materials tab, in the left (View) column, select the computed BOM.
3. In the second (Options) column, expand the **Activation** control and click **Activated**.